Español

Ver un GPG archivo en línea, gratis

Abrir y leer archivos .GPG en línea. Vea el código fuente, registros y texto con resaltado de sintaxis, búsqueda y números de línea, gratis.

Arrastra tu archivo .GPG aquí

Abre tu archivo .GPG aquí mismo.

Elegir archivo
Hasta 50 MB · Más de 160 extensiones de texto y código
Instantáneo. Se abre en segundos
Sin registro. Solo ábrelo
100% gratis. Sin límites de uso

Lo que obtienes por un archivo .GPG

No tenemos un visor dedicado para este formato, por lo que lo identificamos e inspeccionamos en su lugar; honestamente, solo lo que se puede leer del archivo.

01

Suelta tu archivo .GPG

Elígelo o arrástralo. Se lee aquí mismo en tu navegador.

02

Lo identificamos

Leemos los bytes mágicos para saber qué es realmente el archivo, su tipo MIME y si el nombre coincide con el contenido.

03

Ver los detalles

Cualquier metadato que podamos extraer (dimensiones, EXIF/GPS, autor del documento y fechas), una vista hexadecimal, además de texto legible y cadenas encontradas en el interior.

¿Qué es un archivo .GPG?

Texto sin formato que programas, servidores y personas escriben a diario.

Un archivo .GPG es un GNU Privacy Guard Public Keyring desarrollado por la Free Software Foundation. Este archivo de datos contiene normalmente claves públicas utilizadas para cifrado y firmas digitales. Estos archivos se gestionan utilizando la suite de software GnuPG.

Programas que abren archivos .GPG

Windows
Gpg4win (Kleopatra)
macOS
GnuPG (gpg), GPG Suite
Linux
GnuPG (gpg), Seahorse (GNOME Passwords and Keys)
Detalles del formato .GPG
Nombre completoGnuPG Encrypted File
DesarrolladorGnuPG (Free Software Foundation / g10 Code); OpenPGP standard (IETF)
Lanzamiento inicialGnuPG 1.0 in 1999; OpenPGP standardized as RFC 2440 (1998) / RFC 4880 (2007) / RFC 9580 (2024)
CategoríaTexto & Código
Tipo MIMEapplication/pgp-encrypted

Visores relacionados

Cada visor es de uso gratuito.

Preguntas frecuentes

¿Se sube mi archivo .GPG a algún lugar?

No. El archivo se lee y se resalta para usted.

¿Por qué algunos caracteres se ven mal (é, Å‚)?

Eso suele significar que el archivo se guardó en una codificación y se abrió en otra. Detectamos automáticamente UTF-8, UTF-16 y las páginas de códigos Windows-1250/1252 y mostramos cuál se utilizó.

¿Puede manejar archivos de registro enormes?

Sí, hasta 50 MB. Solo se dibujan las líneas en pantalla, por lo que el desplazamiento sigue siendo fluido. Los colores de sintaxis se desactivan para archivos de más de 1,5 MB para mantener la velocidad.

¿Cómo funcionan los filtros de nivel de registro?

Identificamos niveles como ERROR, WARN, INFO y DEBUG en cada línea. Las líneas sin nivel, como los rastreos de pila, permanecen con la entrada superior, por lo que filtrar por errores mantiene el rastreo completo.

¿Puedo editar el archivo?

Este es un visor. Para cambiar el código, descárguelo o cópielo en su editor. La conversión de codificaciones y finales de línea está prevista.

¿Te resultó útil esta herramienta?

Tu valoración nos ayuda a decidir qué herramientas mejorar a continuación.

Sé el primero en valorar esta herramienta.
¿Has encontrado algún problema?